Vulnerability · Published Nov 12, 2024 · Assigned by Rockwell
CVE-2024-10944FactoryTalk® Updater Remote Code Execution
High 8.4
In plain English
A high-severity improper input validation in FactoryTalk Updater from Rockwell Automation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 46% of all known vulnerabilities).
Severity (CVSS 3.1)8.4High
Exploit odds (30 days)0.5%top 54.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
A Remote Code Execution vulnerability exists in the affected product. The vulnerability requires a high level of permissions and exists due to improper input validation resulting in the possibility of a malicious Updated Agent being deployed.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Rockwell Automation | FactoryTalk Updater | <4.20.00 |
Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H