Vulnerability · Published Jan 16, 2024 · Assigned by GitHub_P
CVE-2024-0507Privilege Escalation by Code Injection in the Management Console in GitHub Enterprise Server
Medium 6.5
In plain English
A medium-severity improper input validation in Enterprise Server from GitHub. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 65.8% (higher than 99.3% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code.
Official description
An attacker with access to a Management Console user account with the editor role could escalate privileges through a command injection vulnerability in the Management Console. This vulnerability affected all versions of GitHub Enterprise Server and was fixed in versions 3.11.3, 3.10.5, 3.9.8, and 3.8.13 This vulnerability was reported via the GitHub Bug Bounty program.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| GitHub | Enterprise Server | 3.8.0 – through 3.8.123.9.0 – through 3.9.73.10.0 – through 3.10.43.11.0 – through 3.11.2 |
Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N
References
- https://docs.github.com/en/enterprise-server@3.11/admin/release-notes#3.11.3
- https://docs.github.com/en/enterprise-server@3.10/admin/release-notes#3.10.5
- https://docs.github.com/en/enterprise-server@3.9/admin/release-notes#3.9.8
- https://docs.github.com/en/enterprise-server@3.8/admin/release-notes#3.8.13