Vulnerability · Published Dec 29, 2023 · Assigned by cloudflare
CVE-2023-7080Arbitrary remote code execution within wrangler dev Workers sandbox
High 8.5
In plain English
A high-severity privilege mismanagement in wrangler from Cloudflare. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
The V8 inspector intentionally allows arbitrary code execution within the Workers sandbox for debugging. wrangler dev would previously start an inspector server listening on all network interfaces. This would allow an attacker on the local network to connect to the inspector and run arbitrary code. Additionally, the inspector server did not validate Origin/Host headers, granting an attacker that can trick any user on the local network into opening a malicious website the ability to run code. If wrangler dev --remote was being used, an attacker could access production resources if they were bound to the worker. This issue was fixed in wrangler@3.19.0 and wrangler@2.20.2. Whilst wrangler dev's inspector server listens on local interfaces by default as of wrangler@3.16.0, an SSRF vulnerability in miniflare https://github.com/cloudflare/workers-sdk/security/advisories/GHSA-fwvg-2739-22v7 (CVE-2023-7078) allowed access from the local network until wrangler@3.18.0. wrangler@3.19.0 and wrangler@2.20.2 introduced validation for the Origin/Host headers.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | wrangler | 3.19.0 | GHSA-f8mp-x433-5wpf |
| npm | wrangler | 2.20.2 | GHSA-f8mp-x433-5wpf |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Cloudflare | wrangler | 0 – through 3.0.00 – before 3.19.00 – through 2.0.00 – before 2.20.2 |
Weakness: CWE-269 · Vector: CVSS:3.1/AV:A/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N