Vulnerability · Published Oct 20, 2023 · Assigned by Wordfence
CVE-2023-5109WP Mailto Links – Protect Email Addresses <= 3.1.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode
Medium 6.4
In plain English
A medium-severity cross-site scripting in WP Mailto Links – Protect Email Addresses from onlineoptimisation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities).
Official description
The WP Mailto Links – Protect Email Addresses plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'wpml_mailto' shortcode in versions up to, and including, 3.1.3 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This was partially patched in version 3.1.3 and fully patched in version 3.1.4.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| onlineoptimisation | WP Mailto Links – Protect Email Addresses | 0 – through 3.1.3 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N