Vulnerability · Published Dec 13, 2023 · Assigned by GitHub_M
CVE-2023-50709Denial of service attack on the cube-api endpoint
Medium 6.5
In plain English
A medium-severity improper input validation in cube from cube-js. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 54% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Cube is a semantic layer for building data applications. Prior to version 0.34.34, it is possible to make the entire Cube API unavailable by submitting a specially crafted request to a Cube API endpoint. The issue has been patched in `v0.34.34` and it's recommended that all users exposing Cube APIs to the public internet upgrade to the latest version to prevent service disruption. There are currently no workaround for older versions, and the recommendation is to upgrade.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @cubejs-backend/api-gateway | 0.34.34 | GHSA-9759-3276-g2pm |
Affected products (as reported)
Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
References
- https://github.com/cube-js/cube/security/advisories/GHSA-9759-3276-g2pm x_refsource_CONFIRM
- https://github.com/cube-js/cube/releases/tag/v0.34.34 x_refsource_MISC