Vulnerability · Published Feb 9, 2024 · Assigned by apache

CVE-2023-50291Apache Solr: System Property redaction logic inconsistency can lead to leaked passwords

High 7.5

In plain English

A high-severity security flaw in Apache Solr from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 3.3% (higher than 88% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)3.3%top 11.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Insufficiently Protected Credentials vulnerability in Apache Solr. This issue affects Apache Solr: from 6.0.0 through 8.11.2, from 9.0.0 before 9.3.0. One of the two endpoints that publishes the Solr process' Java system properties, /admin/info/properties, was only setup to hide system properties that had "password" contained in the name. There are a number of sensitive system properties, such as "basicauth" and "aws.secretKey" do not contain "password", thus their values were published via the "/admin/info/properties" endpoint. This endpoint populates the list of System Properties on the home screen of the Solr Admin page, making the exposed credentials visible in the UI. This /admin/info/properties endpoint is protected under the "config-read" permission. Therefore, Solr Clouds with Authorization enabled will only be vulnerable through logged-in users that have the "config-read" permission. Users are recommended to upgrade to version 9.3.0 or 8.11.3, which fixes the issue. A single option now controls hiding Java system property for all endpoints, "-Dsolr.hiddenSysProps". By default all known sensitive properties are hidden (including "-Dbasicauth"), as well as any property with a name containing "secret" or "password". Users who cannot upgrade can also use the following Java system property to fix the issue:   '-Dsolr.redaction.system.pattern=.*(password|secret|basicauth).*'

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12lucene-solr3.6.2+dfsg-23DEBIAN-CVE-2023-50291
Debian:13lucene-solr3.6.2+dfsg-23DEBIAN-CVE-2023-50291
Debian:14lucene-solr3.6.2+dfsg-23DEBIAN-CVE-2023-50291
Mavenorg.apache.solr:solr-core8.11.3GHSA-3hwc-rqwp-v36q
Mavenorg.apache.solr:solr-core9.3.0GHSA-3hwc-rqwp-v36q
Ubuntu:22.04:LTSlucene-solrno fix listedUBUNTU-CVE-2023-50291
Ubuntu:24.04:LTSlucene-solrno fix listedUBUNTU-CVE-2023-50291
Ubuntu:25.10lucene-solrno fix listedUBUNTU-CVE-2023-50291
Ubuntu:26.04:LTSlucene-solrno fix listedUBUNTU-CVE-2023-50291
Ubuntu:26.10lucene-solrno fix listedUBUNTU-CVE-2023-50291

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Solr 6.0.0 – through 8.11.29.0.0 – before 9.3.0

Weakness: CWE-522 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

References