Vulnerability · Published Dec 11, 2023 · Assigned by GitHub_M
CVE-2023-49802MantisBT LinkedCustomFields Cross-site Scripting vulnerability
Medium 6.7
In plain English
A medium-severity cross-site scripting in LinkedCustomFields from mantisbt-plugins. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 52% of all known vulnerabilities).
Official description
The LinkedCustomFields plugin for MantisBT allows users to link values between two custom fields, creating linked drop-downs. Prior to version 2.0.1, cross-site scripting in the MantisBT LinkedCustomFields plugin allows Javascript execution, when a crafted Custom Field is linked via the plugin and displayed when reporting a new Issue or editing an existing one. This issue is fixed in version 2.0.1. As a workaround, one may utilize MantisBT's default Content Security Policy, which blocks script execution.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| mantisbt-plugins | LinkedCustomFields | < 2.0.1 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:L
References
- https://github.com/mantisbt-plugins/LinkedCustomFields/security/advisories/GHSA-2f37-9xpx-5hhw x_refsource_CONFIRM
- https://github.com/mantisbt-plugins/LinkedCustomFields/issues/10 x_refsource_MISC
- https://github.com/mantisbt-plugins/LinkedCustomFields/pull/11 x_refsource_MISC
- https://github.com/mantisbt-plugins/LinkedCustomFields/commit/30e5ae751e40d7ae18bfd794fd48671477b3d286 x_refsource_MISC