Vulnerability · Published Jan 10, 2024 · Assigned by GitHub_M

CVE-2023-49295quic-go's path validation mechanism can cause denial of service

Medium 6.4

In plain English

A medium-severity uncontrolled resource consumption in quic-go from quic-go. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 68% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.4Medium
Exploit odds (30 days)1.2%top 31.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

quic-go is an implementation of the QUIC protocol (RFC 9000, RFC 9001, RFC 9002) in Go. An attacker can cause its peer to run out of memory sending a large number of PATH_CHALLENGE frames. The receiver is supposed to respond to each PATH_CHALLENGE frame with a PATH_RESPONSE frame. The attacker can prevent the receiver from sending out (the vast majority of) these PATH_RESPONSE frames by collapsing the peers congestion window (by selectively acknowledging received packets) and by manipulating the peer's RTT estimate. This vulnerability has been patched in versions 0.37.7, 0.38.2 and 0.39.4.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12golang-github-lucas-clemente-quic-gono fix listedDEBIAN-CVE-2023-49295
Debian:13golang-github-lucas-clemente-quic-go0.38.2-1DEBIAN-CVE-2023-49295
Debian:14golang-github-lucas-clemente-quic-go0.38.2-1DEBIAN-CVE-2023-49295
Gogithub.com/quic-go/quic-go0.38.2GHSA-ppxx-5m9h-6vxf
Gogithub.com/quic-go/quic-go0.37.7, 0.38.2, 0.39.4, 0.40.1GO-2024-2459
Gogithub.com/quic-go/quic-go0.37.7GHSA-ppxx-5m9h-6vxf
Gogithub.com/quic-go/quic-go0.40.1GHSA-ppxx-5m9h-6vxf
Gogithub.com/quic-go/quic-go0.39.4GHSA-ppxx-5m9h-6vxf
Ubuntu:22.04:LTSgolang-github-lucas-clemente-quic-gono fix listedUBUNTU-CVE-2023-49295
Ubuntu:24.04:LTSgolang-github-lucas-clemente-quic-gono fix listedUBUNTU-CVE-2023-49295
Ubuntu:25.10golang-github-lucas-clemente-quic-gono fix listedUBUNTU-CVE-2023-49295
Ubuntu:26.04:LTSgolang-github-lucas-clemente-quic-gono fix listedUBUNTU-CVE-2023-49295
Ubuntu:26.10golang-github-lucas-clemente-quic-gono fix listedUBUNTU-CVE-2023-49295

Affected products (as reported)

VendorProductVersions
quic-go quic-go = 0.40.0>= 0.39.0, < 0.39.4>= 0.38.0, < 0.38.2< 0.37.7

Weakness: CWE-400 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:H

References