Vulnerability · Published Dec 4, 2023 · Assigned by GitHub_M

CVE-2023-49285Denial of Service in HTTP Message Processing in Squid

High 8.6

In plain English

A high-severity security flaw in squid from squid-cache. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 88.1% (higher than 99.8% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.6High
Exploit odds (30 days)88.1%top 0.2% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Squid is a caching proxy for the Web supporting HTTP, HTTPS, FTP, and more. Due to a Buffer Overread bug Squid is vulnerable to a Denial of Service attack against Squid HTTP Message processing. This bug is fixed by Squid version 6.5. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8libecap1.0.1-2.module_el8.6.0+3048+383bc947ALSA-2024:0046
AlmaLinux:8libecap1.0.1-2.module_el8.6.0+2741+01592ae8ALSA-2024:0046
AlmaLinux:8libecap-devel1.0.1-2.module_el8.6.0+3048+383bc947ALSA-2024:0046
AlmaLinux:8libecap-devel1.0.1-2.module_el8.6.0+2741+01592ae8ALSA-2024:0046
AlmaLinux:8squid7:4.15-7.module_el8.9.0+3708+6acaac63.5ALSA-2024:0046
AlmaLinux:9squid7:5.5-6.el9_3.5ALSA-2024:0071
Alpine:v3.20squid6.5-r0ALPINE-CVE-2023-49285
Alpine:v3.21squid6.5-r0ALPINE-CVE-2023-49285
Alpine:v3.22squid6.5-r0ALPINE-CVE-2023-49285
Alpine:v3.23squid6.5-r0ALPINE-CVE-2023-49285
Alpine:v3.24squid6.5-r0ALPINE-CVE-2023-49285
Debian:12squid5.7-2+deb12u1DSA-5637-1
Debian:12squid5.7-2+deb12u1DEBIAN-CVE-2023-49285
Debian:13squid6.5-1DEBIAN-CVE-2023-49285
Debian:14squid6.5-1DEBIAN-CVE-2023-49285
Rocky Linux:8libecap0:1.0.1-2.module+el8.9.0+1437+df5ea8f0RLSA-2024:0046
Rocky Linux:8squid7:4.15-7.module+el8.9.0+1568+6d4fd5d4.1RLSA-2024:0046
Ubuntu:22.04:LTSsquid5.7-0ubuntu0.22.04.3USN-6594-1
Ubuntu:22.04:LTSsquid5.7-0ubuntu0.22.04.3UBUNTU-CVE-2023-49285
Ubuntu:24.04:LTSsquid6.5-1ubuntu1UBUNTU-CVE-2023-49285

Affected products (as reported)

VendorProductVersions
squid-cache squid >= 2.2, < 6.5

Weakness: CWE-126 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H

References