Vulnerability · Published Dec 1, 2023 · Assigned by GitHub_M

CVE-2023-49277Reflected Cross-site Scripting Vulnerability in dpaste

High 8.3

In plain English

A high-severity cross-site scripting in dpaste from DarrenOfficial. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 44% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.3High
Exploit odds (30 days)0.5%top 55.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

dpaste is an open source pastebin application written in Python using the Django framework. A security vulnerability has been identified in the expires parameter of the dpaste API, allowing for a POST Reflected XSS attack. This vulnerability can be exploited by an attacker to execute arbitrary JavaScript code in the context of a user's browser, potentially leading to unauthorized access, data theft, or other malicious activities. Users are strongly advised to upgrade to dpaste release v3.8 or later versions, as dpaste versions older than v3.8 are susceptible to the identified security vulnerability. No known workarounds have been identified, and applying the patch is the most effective way to remediate the vulnerability.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIdpaste3.8GHSA-r8j9-5cj7-cv39
PyPIdpaste3.8PYSEC-2026-1317

Affected products (as reported)

VendorProductVersions
DarrenOfficial dpaste < 3.8

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:H/A:H

References