Vulnerability · Published Oct 20, 2023 · Assigned by Wordfence
CVE-2023-4919iframe <= 4.6 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'iframe' Shortcode
Medium 6.4
In plain English
A medium-severity cross-site scripting in iframe from webvitaly. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 49% of all known vulnerabilities).
Official description
The iframe plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the `iframe` shortcode in versions up to, and including, 4.6 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level permission and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This was partially patched in version 4.6 and fully patched in version 4.7.
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
References
- https://www.wordfence.com/threat-intel/vulnerabilities/id/3706deed-55f2-4dfb-bfed-7a14872cd15a?source=cve
- https://plugins.trac.wordpress.org/browser/iframe/tags/4.5/iframe.php#L28
- https://plugins.trac.wordpress.org/browser/iframe/tags/4.5/iframe.php#L40
- https://plugins.trac.wordpress.org/changeset/2970787/iframe#file4