Vulnerability · Published Nov 29, 2023 · Assigned by GitHub_M

CVE-2023-49083cryptography vulnerable to NULL-dereference when loading PKCS7 certificates

Medium 5.9

In plain English

A medium-severity null pointer dereference in cryptography from pyca. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 63% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.9Medium
Exploit odds (30 days)1.0%top 37.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

cryptography is a package designed to expose cryptographic primitives and recipes to Python developers. Calling `load_pem_pkcs7_certificates` or `load_der_pkcs7_certificates` could lead to a NULL-pointer dereference and segfault. Exploitation of this vulnerability poses a serious risk of Denial of Service (DoS) for any application attempting to deserialize a PKCS7 blob/certificate. The consequences extend to potential disruptions in system availability and stability. This vulnerability has been patched in version 41.0.6.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8python3-cryptography3.2.1-8.el8_10ALSA-2025:14553
AlmaLinux:9python3-cryptography36.0.1-5.el9_6ALSA-2025:15874
AlmaLinux:8python3.11-cryptography37.0.2-6.el8ALSA-2024:3105
AlmaLinux:9python3.11-cryptography37.0.2-6.el9ALSA-2024:2337
Debian:12python-cryptography38.0.4-3+deb12u1DEBIAN-CVE-2023-49083
Debian:13python-cryptography41.0.7-1DEBIAN-CVE-2023-49083
Debian:14python-cryptography41.0.7-1DEBIAN-CVE-2023-49083
PyPIcryptography41.0.6GHSA-jfhm-5ghh-2f97
PyPIcryptography41.0.6PYSEC-2023-254
Rocky Linux:8python-cryptography0:3.2.1-8.el8_10RLSA-2025:14553
Rocky Linux:9python-cryptography0:36.0.1-5.el9_6RLSA-2025:15874
Rocky Linux:8python3.11-cryptography0:37.0.2-6.el8RLSA-2024:3105
Rocky Linux:9python3.11-cryptography0:37.0.2-6.el9RLSA-2024:2337
Ubuntu:22.04:LTSpython-cryptography3.4.8-1ubuntu2.1USN-6539-1
Ubuntu:22.04:LTSpython-cryptography3.4.8-1ubuntu2.1UBUNTU-CVE-2023-49083

Affected products (as reported)

VendorProductVersions
pyca cryptography >= 3.1, < 41.0.6

Weakness: CWE-476 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

References