Vulnerability · Published Nov 24, 2023 · Assigned by apache
CVE-2023-48796Apache dolphinscheduler sensitive information disclosure
High 7.5
In plain English
A high-severity information exposure in Apache DolphinScheduler from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 68% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache DolphinScheduler. The information exposed to unauthorized actors may include sensitive data such as database credentials. Users who can't upgrade to the fixed version can also set environment variable `MANAGEMENT_ENDPOINTS_WEB_EXPOSURE_INCLUDE=health,metrics,prometheus` to workaround this, or add the following section in the `application.yaml` file ``` management: endpoints: web: exposure: include: health,metrics,prometheus ``` This issue affects Apache DolphinScheduler: from 3.0.0 before 3.0.2. Users are recommended to upgrade to version 3.0.2, which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.dolphinscheduler:dolphinscheduler | 3.0.2 | GHSA-4vvc-r4p4-qgrr |
| PyPI | apache-dolphinscheduler | 3.0.2 | GHSA-4vvc-r4p4-qgrr |
| PyPI | apache-dolphinscheduler | 3.0.2 | PYSEC-2023-268 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache DolphinScheduler | 3.0.0 – before 3.0.2 |
Weakness: CWE-200