Vulnerability · Published Feb 20, 2024 · Assigned by GitHub_M

CVE-2023-47635Decidim vulnerable to possible CSRF attack at questionnaire templates preview

Medium 4.5

In plain English

A medium-severity server-side request forgery in decidim from decidim. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 24% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.5Medium
Exploit odds (30 days)0.3%top 75.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Decidim is a participatory democracy framework. Starting in version 0.23.0 and prior to versions 0.27.5 and 0.28.0, the CSRF authenticity token check is disabled for the questionnaire templates preview. The issue does not imply a serious security thread as you need to have access also to the session cookie in order to see this resource. This URL does not allow modifying the resource but it may allow attackers to gain access to information which was not meant to be public. The issue is fixed in version 0.27.5 and 0.28.0. As a workaround, disable the templates functionality or remove all available templates.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
RubyGemsdecidim-templates0.27.5GHSA-f3qm-vfc3-jg6v

Affected products (as reported)

VendorProductVersions
decidim decidim >= 0.23.0, < 0.27.5

Weakness: CWE-918 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:N/A:N

References