Vulnerability · Published Nov 9, 2023 · Assigned by GitHub_M

CVE-2023-47110Any value can be changed in the configuration table by an employee having access to block reassurance module

Critical 9.1

In plain English

A critical-severity improper access control in blockreassurance from PrestaShop. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 36% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.1Critical
Exploit odds (30 days)0.4%top 63.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

blockreassurance adds an information block aimed at offering helpful information to reassure customers that their store is trustworthy. An ajax function in module blockreassurance allows modifying any value in the configuration table. This vulnerability has been patched in version 5.1.4.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistprestashop/blockreassurance5.1.4GHSA-xfm3-hjcc-gv78

Affected products (as reported)

VendorProductVersions
PrestaShop blockreassurance <= 5.1.3

Weakness: CWE-284 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:H

References