Vulnerability · Published Nov 10, 2023 · Assigned by GitHub_M
CVE-2023-46729Sentry Next.js vulnerable to SSRF via Next.js SDK tunnel endpoint
Critical 9.3
In plain English
A critical-severity server-side request forgery in sentry-javascript from getsentry. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
sentry-javascript provides Sentry SDKs for JavaScript. An unsanitized input of Next.js SDK tunnel endpoint allows sending HTTP requests to arbitrary URLs and reflecting the response back to the user. This issue only affects users who have Next.js SDK tunneling feature enabled. The problem has been fixed in version 7.77.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @sentry/nextjs | 7.77.0 | GHSA-2rmr-xw8m-22q9 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| getsentry | sentry-javascript | >= 7.26.0, < 7.77.0 |
Weakness: CWE-918 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N