Vulnerability · Published Nov 1, 2023 · Assigned by GitHub_M

CVE-2023-46724SQUID-2023:4 Denial of Service in SSL Certificate validation

High 8.6

In plain English

A high-severity out-of-bounds read in squid from squid-cache. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.8% (higher than 87% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.6High
Exploit odds (30 days)2.8%top 13.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Squid is a caching proxy for the Web. Due to an Improper Validation of Specified Index bug, Squid versions 3.3.0.1 through 5.9 and 6.0 prior to 6.4 compiled using `--with-openssl` are vulnerable to a Denial of Service attack against SSL Certificate validation. This problem allows a remote server to perform Denial of Service against Squid Proxy by initiating a TLS Handshake with a specially crafted SSL Certificate in a server certificate chain. This attack is limited to HTTPS and SSL-Bump. This bug is fixed in Squid version 6.4. In addition, patches addressing this problem for the stable releases can be found in Squid's patch archives. Those who you use a prepackaged version of Squid should refer to the package vendor for availability information on updated packages.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8libecap1.0.1-2.module_el8.6.0+3048+383bc947ALSA-2024:0046
AlmaLinux:8libecap1.0.1-2.module_el8.6.0+2741+01592ae8ALSA-2024:0046
AlmaLinux:8libecap-devel1.0.1-2.module_el8.6.0+3048+383bc947ALSA-2024:0046
AlmaLinux:8libecap-devel1.0.1-2.module_el8.6.0+2741+01592ae8ALSA-2024:0046
AlmaLinux:8squid7:4.15-7.module_el8.9.0+3708+6acaac63.5ALSA-2024:0046
AlmaLinux:9squid7:5.5-6.el9_3.5ALSA-2024:0071
Alpine:v3.20squid6.4-r0ALPINE-CVE-2023-46724
Alpine:v3.21squid6.4-r0ALPINE-CVE-2023-46724
Alpine:v3.22squid6.4-r0ALPINE-CVE-2023-46724
Alpine:v3.23squid6.4-r0ALPINE-CVE-2023-46724
Alpine:v3.24squid6.4-r0ALPINE-CVE-2023-46724
Debian:12squid5.7-2+deb12u1DSA-5637-1
Debian:12squid5.7-2+deb12u1DEBIAN-CVE-2023-46724
Debian:13squid6.5-1DEBIAN-CVE-2023-46724
Debian:14squid6.5-1DEBIAN-CVE-2023-46724
Rocky Linux:8libecap0:1.0.1-2.module+el8.9.0+1437+df5ea8f0RLSA-2024:0046
Rocky Linux:8squid7:4.15-7.module+el8.9.0+1568+6d4fd5d4.1RLSA-2024:0046
Ubuntu:22.04:LTSsquid5.7-0ubuntu0.22.04.2USN-6500-1
Ubuntu:22.04:LTSsquid5.7-0ubuntu0.22.04.2UBUNTU-CVE-2023-46724
Ubuntu:24.04:LTSsquid6.1-2ubuntu2UBUNTU-CVE-2023-46724

Affected products (as reported)

VendorProductVersions
squid-cache squid >= 3.3.0.1, < 6.4

Weakness: CWE-125, CWE-129, CWE-786, CWE-823, CWE-1285 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H

References