Vulnerability · Published Oct 31, 2023 · Assigned by GitHub_M
CVE-2023-46248Overwrite of builtin Cody commands facilitates RCE
Critical 9.1
In plain English
A critical-severity security flaw in cody from sourcegraph. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.3% (higher than 70% of all known vulnerabilities).
Official description
Cody is an artificial intelligence (AI) coding assistant. The Cody AI VSCode extension versions 0.10.0 through 0.14.0 are vulnerable to Remote Code Execution under certain conditions. An attacker in control of a malicious repository could modify the Cody configuration file `.vscode/cody.json` and overwrite Cody commands. If a user with the extension installed opens this malicious repository and runs a Cody command such as /explain or /doc, this could allow arbitrary code execution on the user's machine. The vulnerability is rated as critical severity, but with low exploitability. It requires the user to have a malicious repository loaded and execute the overwritten command in VS Code. The issue is exploitable regardless of the user blocking code execution on a repository through VS Code Workspace Trust. The issue was found during a regular 3rd party penetration test. The maintainers of Cody do not have evidence of open source repositories having malicious `.vscode/cody.json` files to exploit this vulnerability. The issue is fixed in version 0.14.1 of the Cody VSCode extension. In case users can't promptly upgrade, they should not open any untrusted repositories with the Cody extension loaded.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| sourcegraph | cody | >= 0.10.0, < 0.14.1 |
Weakness: CWE-15 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
References
- https://github.com/sourcegraph/cody/security/advisories/GHSA-8wmq-fwv7-xmwq x_refsource_CONFIRM
- https://github.com/sourcegraph/cody/pull/1414 x_refsource_MISC