Vulnerability · Published Oct 19, 2023 · Assigned by apache
CVE-2023-46227Apache inlong has an Arbitrary File Read Vulnerability
High 7.5
In plain English
A high-severity unsafe deserialization in Apache InLong from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.4% (higher than 72% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Deserialization of Untrusted Data Vulnerability in Apache Software Foundation Apache InLong. This issue affects Apache InLong: from 1.4.0 through 1.8.0, the attacker can use \t to bypass. Users are advised to upgrade to Apache InLong's 1.9.0 or cherry-pick [1] to solve it. [1] https://github.com/apache/inlong/pull/8814
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.inlong:manager-common | 1.9.0 | GHSA-jj32-3pf5-5mv5 |
| Maven | org.apache.inlong:manager-pojo | 1.9.0 | GHSA-jj32-3pf5-5mv5 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache InLong | 1.4.0 – through 1.8.0 |
Weakness: CWE-502 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
References
- https://lists.apache.org/thread/m8txor4f76tmrxksrmc87tw42g57nz33 vendor-advisory