Vulnerability · Published Oct 16, 2023 · Assigned by GitHub_M
CVE-2023-45149Password of talk conversations can be bruteforced in Nextcloud
Medium 4.3
In plain English
A medium-severity security flaw in security-advisories from nextcloud. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 49% of all known vulnerabilities).
Official description
Nextcloud talk is a chat module for the Nextcloud server platform. In affected versions brute force protection of public talk conversation passwords can be bypassed, as there was an endpoint validating the conversation password without registering bruteforce attempts. It is recommended that the Nextcloud Talk app is upgraded to 15.0.8, 16.0.6 or 17.1.1. There are no known workarounds for this vulnerability.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| nextcloud | security-advisories | >= 15.0.0, < 15.0.8>= 16.0.0, < 16.0.6>= 17.0.0, < 17.1.1 |
Weakness: CWE-307 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-7rf8-pqmj-rpqv x_refsource_CONFIRM
- https://github.com/nextcloud/spreed/pull/10545 x_refsource_MISC
- https://hackerone.com/reports/2094473 x_refsource_MISC