Vulnerability · Published Oct 10, 2023 · Assigned by GitHub_M

CVE-2023-45129matrix-synapse vulnerable to denial of service due to malicious server ACL events

Medium 4.9

In plain English

A medium-severity resource allocation without limits in synapse from matrix-org. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.4% (higher than 72% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.9Medium
Exploit odds (30 days)1.4%top 27.5% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Synapse is an open-source Matrix homeserver written and maintained by the Matrix.org Foundation. Prior to version 1.94.0, a malicious server ACL event can impact performance temporarily or permanently leading to a persistent denial of service. Homeservers running on a closed federation (which presumably do not need to use server ACLs) are not affected. Server administrators are advised to upgrade to Synapse 1.94.0 or later. As a workaround, rooms with malicious server ACL events can be purged and blocked using the admin API.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.20synapse1.94.0-r0ALPINE-CVE-2023-45129
Alpine:v3.21synapse1.94.0-r0ALPINE-CVE-2023-45129
Alpine:v3.22synapse1.94.0-r0ALPINE-CVE-2023-45129
Alpine:v3.23synapse1.94.0-r0ALPINE-CVE-2023-45129
Alpine:v3.24synapse1.94.0-r0ALPINE-CVE-2023-45129
Debian:14matrix-synapse1.94.0-1DEBIAN-CVE-2023-45129
PyPImatrix-synapse1.94.0GHSA-5chr-wjw5-3gq4
PyPImatrix-synapse1.94.0PYSEC-2023-199
Ubuntu:22.04:LTSmatrix-synapseno fix listedUBUNTU-CVE-2023-45129

Affected products (as reported)

VendorProductVersions
matrix-org synapse < 1.94.0

Weakness: CWE-770 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H

References