Vulnerability · Published Sep 21, 2023 · Assigned by AHA

CVE-2023-4504OpenPrinting CUPS/libppd Postscript Parsing Heap Overflow

High 7.0

In plain English

A high-severity heap buffer overflow in CUPS from OpenPrinting. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 51% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.0High
Exploit odds (30 days)0.6%top 49.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack tooling1Public PoC

Official description

Due to failure in validating the length provided by an attacker-crafted PPD PostScript document, CUPS and libppd are susceptible to a heap-based buffer overflow and possibly code execution. This issue has been fixed in CUPS version 2.4.7, released in September of 2023.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.20cups2.4.7-r0ALPINE-CVE-2023-4504
Alpine:v3.21cups2.4.7-r0ALPINE-CVE-2023-4504
Alpine:v3.22cups2.4.7-r0ALPINE-CVE-2023-4504
Alpine:v3.23cups2.4.7-r0ALPINE-CVE-2023-4504
Alpine:v3.24cups2.4.7-r0ALPINE-CVE-2023-4504
Debian:12cups2.4.2-3+deb12u2DEBIAN-CVE-2023-4504
Debian:13cups2.4.2-6DEBIAN-CVE-2023-4504
Debian:14cups2.4.2-6DEBIAN-CVE-2023-4504
Ubuntu:22.04:LTScups2.4.1op1-1ubuntu4.7USN-6391-1
Ubuntu:22.04:LTScups2.4.1op1-1ubuntu4.7UBUNTU-CVE-2023-4504
Ubuntu:22.04:LTSlibppdno fix listedUBUNTU-CVE-2023-4504

Affected products (as reported)

VendorProductVersions
OpenPrinting CUPS 0 – before 2.4.6
OpenPrinting libppd 0 – before d09348b

Weakness: CWE-122 · Vector: CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

References