Vulnerability · Published Dec 19, 2023 · Assigned by apache

CVE-2023-43826Apache Guacamole: Integer overflow in handling of VNC image buffers

High 7.5

In plain English

A high-severity integer overflow in Apache Guacamole from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 60% of all known vulnerabilities).

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.9%top 40.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Apache Guacamole 1.5.3 and older do not consistently ensure that values received from a VNC server will not result in integer overflow. If a user connects to a malicious or compromised VNC server, specially-crafted data could result in memory corruption, possibly allowing arbitrary code to be executed with the privileges of the running guacd process. Users are recommended to upgrade to version 1.5.4, which fixes this issue.

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Guacamole 0 – through 1.5.3

Weakness: CWE-190 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

References