Vulnerability · Published Nov 27, 2023 · Assigned by apache

CVE-2023-43701Apache Superset: Stored XSS on API endpoint

Medium 4.3

In plain English

A medium-severity cross-site scripting in Apache Superset from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 63% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.3Medium
Exploit odds (30 days)1.0%top 36.9% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Improper payload validation and an improper REST API response type, made it possible for an authenticated malicious actor to store malicious code into Chart's metadata, this code could get executed if a user specifically accesses a specific deprecated API endpoint. This issue affects Apache Superset versions prior to 2.1.2.  Users are recommended to upgrade to version 2.1.2, which fixes this issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIapache-superset2.1.2GHSA-wq8q-99p5-xfrw
PyPIapache-superset2.1.2PYSEC-2026-1190

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Superset 0 – before 2.1.2

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

References