Vulnerability · Published Oct 9, 2023 · Assigned by GitHub_M

CVE-2023-43641libcue vulnerable to out-of-bounds array access

High 8.8

In plain English

A high-severity out-of-bounds write in libcue from lipnitsk. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 17.2% (higher than 97% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)17.2%top 2.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

libcue provides an API for parsing and extracting data from CUE sheets. Versions 2.2.1 and prior are vulnerable to out-of-bounds array access. A user of the GNOME desktop environment can be exploited by downloading a cue sheet from a malicious webpage. Because the file is saved to `~/Downloads`, it is then automatically scanned by tracker-miners. And because it has a .cue filename extension, tracker-miners use libcue to parse the file. The file exploits the vulnerability in libcue to gain code execution. This issue is patched in version 2.3.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.20libcue2.2.1-r2ALPINE-CVE-2023-43641
Alpine:v3.21libcue2.2.1-r2ALPINE-CVE-2023-43641
Alpine:v3.22libcue2.2.1-r2ALPINE-CVE-2023-43641
Alpine:v3.23libcue2.2.1-r2ALPINE-CVE-2023-43641
Alpine:v3.24libcue2.2.1-r2ALPINE-CVE-2023-43641
Debian:12libcue2.2.1-4+deb12u1DSA-5524-1
Debian:12libcue2.2.1-4+deb12u1DEBIAN-CVE-2023-43641
Debian:13libcue2.2.1-4.1DEBIAN-CVE-2023-43641
Debian:14libcue2.2.1-4.1DEBIAN-CVE-2023-43641
Ubuntu:22.04:LTSlibcue2.2.1-3ubuntu0.1USN-6423-1
Ubuntu:22.04:LTSlibcue2.2.1-3ubuntu0.1UBUNTU-CVE-2023-43641
Ubuntu:24.04:LTSlibcue2.2.1-4ubuntu1UBUNTU-CVE-2023-43641

Affected products (as reported)

VendorProductVersions
lipnitsk libcue <= 2.2.1

Weakness: CWE-787 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

References