Actively exploited · Published Nov 30, 2023 · Assigned by apple
CVE-2023-42917
High 8.8 Exploited
In plain English
A high-severity out-of-bounds write in iOS and iPadOS from Apple. Attackers are actively exploiting it in the wild (listed by CISA on December 4, 2023). The chance it is exploited in the next 30 days is estimated at 9.3% (higher than 95% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
CISA guidance
Apply remediations or mitigations per vendor instructions or discontinue use of the product if remediation or mitigations are unavailable.
Federal agencies must remediate by Dec 25, 2023.
Official description
A memory corruption vulnerability was addressed with improved locking. This issue is fixed in iOS 17.1.2 and iPadOS 17.1.2, macOS Sonoma 14.1.2, Safari 17.1.2. Processing web content may lead to arbitrary code execution. Apple is aware of a report that this issue may have been exploited against versions of iOS before iOS 16.7.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:8 | webkit2gtk3 | 2.42.5-1.el8 | ALSA-2024:2982 |
| AlmaLinux:8 | webkit2gtk3 | 2.40.5-1.el8_9.1.alma.1 | ALSA-2023:7716 |
| AlmaLinux:9 | webkit2gtk3 | 2.40.5-1.el9_3.1 | ALSA-2023:7715 |
| AlmaLinux:8 | webkit2gtk3-devel | 2.42.5-1.el8 | ALSA-2024:2982 |
| AlmaLinux:8 | webkit2gtk3-devel | 2.40.5-1.el8_9.1.alma.1 | ALSA-2023:7716 |
| AlmaLinux:9 | webkit2gtk3-devel | 2.40.5-1.el9_3.1 | ALSA-2023:7715 |
| AlmaLinux:8 | webkit2gtk3-jsc | 2.40.5-1.el8_9.1.alma.1 | ALSA-2023:7716 |
| AlmaLinux:8 | webkit2gtk3-jsc | 2.42.5-1.el8 | ALSA-2024:2982 |
| AlmaLinux:9 | webkit2gtk3-jsc | 2.40.5-1.el9_3.1 | ALSA-2023:7715 |
| AlmaLinux:8 | webkit2gtk3-jsc-devel | 2.42.5-1.el8 | ALSA-2024:2982 |
| AlmaLinux:8 | webkit2gtk3-jsc-devel | 2.40.5-1.el8_9.1.alma.1 | ALSA-2023:7716 |
| AlmaLinux:9 | webkit2gtk3-jsc-devel | 2.40.5-1.el9_3.1 | ALSA-2023:7715 |
| Debian:12 | webkit2gtk | 2.42.3-1~deb12u1 | DSA-5575-1 |
| Debian:12 | webkit2gtk | 2.42.3-1~deb12u1 | DEBIAN-CVE-2023-42917 |
| Debian:13 | webkit2gtk | 2.42.3-1 | DEBIAN-CVE-2023-42917 |
| Debian:14 | webkit2gtk | 2.42.3-1 | DEBIAN-CVE-2023-42917 |
| Debian:12 | wpewebkit | no fix listed | DEBIAN-CVE-2023-42917 |
| Debian:13 | wpewebkit | 2.42.3-1 | DEBIAN-CVE-2023-42917 |
| Debian:14 | wpewebkit | 2.42.3-1 | DEBIAN-CVE-2023-42917 |
| Rocky Linux:8 | webkit2gtk3 | 0:2.40.5-1.el8_9.1 | RLSA-2023:7716 |
| Ubuntu:22.04:LTS | qtwebkit-opensource-src | no fix listed | UBUNTU-CVE-2023-42917 |
| Ubuntu:24.04:LTS | qtwebkit-opensource-src | no fix listed | UBUNTU-CVE-2023-42917 |
| Ubuntu:22.04:LTS | webkit2gtk | 2.42.3-0ubuntu0.22.04.1 | USN-6545-1 |
| Ubuntu:22.04:LTS | webkit2gtk | 2.42.3-0ubuntu0.22.04.1 | UBUNTU-CVE-2023-42917 |
| Ubuntu:24.04:LTS | webkit2gtk | 2.42.3-1 | UBUNTU-CVE-2023-42917 |
| Ubuntu:22.04:LTS | wpewebkit | no fix listed | UBUNTU-CVE-2023-42917 |
Affected products (as reported)
Weakness: CWE-787 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
References
- https://support.apple.com/en-us/HT214033
- https://support.apple.com/en-us/HT214032
- https://support.apple.com/en-us/HT214031
- https://support.apple.com/kb/HT214033
- http://www.openwall.com/lists/oss-security/2023/12/05/1
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/P5LQS6VEI7VIZNC7QGQ62EOV45R5RJIR/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/AD2KIHHCUBQC2YYH3FJWAHI5BG3QETOH/
- https://support.apple.com/kb/HT214034
- https://www.debian.org/security/2023/dsa-5575
- http://seclists.org/fulldisclosure/2023/Dec/3
- http://seclists.org/fulldisclosure/2023/Dec/4
- http://seclists.org/fulldisclosure/2023/Dec/5
- http://seclists.org/fulldisclosure/2023/Dec/8
- http://seclists.org/fulldisclosure/2023/Dec/13
- http://seclists.org/fulldisclosure/2023/Dec/12
- https://security.gentoo.org/glsa/202401-04
- https://support.apple.com/kb/HT214062
- http://seclists.org/fulldisclosure/2024/Jan/35
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2023-42917 government-resource