Vulnerability · Published Sep 21, 2023 · Assigned by GitHub_M
CVE-2023-42810systeminformation SSID Command Injection Vulnerability
Critical 9.8
In plain English
A critical-severity command injection in systeminformation from sebhildebrandt. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.2% (higher than 83% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
systeminformation is a System Information Library for Node.JS. Versions 5.0.0 through 5.21.6 have a SSID Command Injection Vulnerability. The problem was fixed with a parameter check in version 5.21.7. As a workaround, check or sanitize parameter strings that are passed to `wifiConnections()`, `wifiNetworks()` (string only).
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:14 | node-systeminformation | no fix listed | DEBIAN-CVE-2023-42810 |
| npm | systeminformation | 5.21.7 | GHSA-gx6r-qc2v-3p3v |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| sebhildebrandt | systeminformation | >= 5.0.0, < 5.21.7 |
Weakness: CWE-77 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H