Vulnerability · Published Nov 27, 2023 · Assigned by apache

CVE-2023-42501Apache Superset: Unnecessary read permissions within the Gamma role

Medium 4.3

In plain English

A medium-severity incorrect default permissions in Apache Superset from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 59% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.3Medium
Exploit odds (30 days)0.9%top 41.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Unnecessary read permissions within the Gamma role would allow authenticated users to read configured CSS templates and annotations. This issue affects Apache Superset: before 2.1.2. Users should upgrade to version or above 2.1.2 and run `superset init` to reconstruct the Gamma role or remove `can_read` permission from the mentioned resources.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIapache-superset2.1.2GHSA-vv65-fjfj-4736
PyPIapache-superset2.1.2PYSEC-2026-1188

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Superset 0 – before 2.1.2

Weakness: CWE-276 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

References