Vulnerability · Published Sep 19, 2023 · Assigned by GitHub_M

CVE-2023-41890Sustainsys.Saml2 Insufficient Identity Provider Issuer Validation

High 7.5

In plain English

A high-severity security flaw in Saml2 from Sustainsys. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 55% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.8%top 44.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Sustainsys.Saml2 library adds SAML2P support to ASP.NET web sites, allowing the web site to act as a SAML2 Service Provider. Prior to versions 1.0.3 and 2.9.2, when a response is processed, the issuer of the Identity Provider is not sufficiently validated. This could allow a malicious identity provider to craft a Saml2 response that is processed as if issued by another identity provider. It is also possible for a malicious end user to cause stored state intended for one identity provider to be used when processing the response from another provider. An application is impacted if they rely on any of these features in their authentication/authorization logic: the issuer of the generated identity and claims; or items in the stored request state (AuthenticationProperties). This issue is patched in versions 2.9.2 and 1.0.3. The `AcsCommandResultCreated` notification can be used to add the validation required if an upgrade to patched packages is not possible.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
NuGetkentor.authservicesno fix listedGHSA-fv2h-753j-9g39
NuGetsustainsys.saml21.0.3GHSA-fv2h-753j-9g39
NuGetsustainsys.saml22.9.2GHSA-fv2h-753j-9g39

Affected products (as reported)

VendorProductVersions
Sustainsys Saml2 < 1.0.3>= 2.0.0, < 2.9.2

Weakness: CWE-289, CWE-294 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

References