Vulnerability · Published Dec 5, 2023 · Assigned by apache
CVE-2023-41835Apache Struts: excessive disk usage
High 7.5
In plain English
A high-severity security flaw in Apache Struts from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 7.3% (higher than 94% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
When a Multipart request is performed but some of the fields exceed the maxStringLength limit, the upload files will remain in struts.multipart.saveDir even if the request has been denied. Users are recommended to upgrade to versions Struts 2.5.32 or 6.1.2.2 or Struts 6.3.0.1 or greater, which fixe this issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.struts:struts2-core | 6.3.0.1 | GHSA-729q-fcgp-r5xh |
| Maven | org.apache.struts:struts2-core | 6.1.2.2 | GHSA-729q-fcgp-r5xh |
| Maven | org.apache.struts:struts2-core | 2.5.32 | GHSA-729q-fcgp-r5xh |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Struts | 2.0.0 – through 2.5.316.1.2.1 – through 6.3.0 |
Weakness: CWE-459 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H