Vulnerability · Published Sep 14, 2023 · Assigned by apache
CVE-2023-41267Apache HDFS Provider error message suggested installation of incorrect pip package
High 7.8
In plain English
A high-severity security flaw in Apache Airflow HDFS Provider from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 49% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
In the Apache Airflow HDFS Provider, versions prior to 4.1.1, a documentation info pointed users to an install incorrect pip package. As this package name was unclaimed, in theory, an attacker could claim this package and provide code that would be executed when this package was installed. The Airflow team has since taken ownership of the package (neutralizing the risk), and fixed the doc strings in version 4.1.1
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | apache-airflow-providers-apache-hdfs | 4.1.1 | GHSA-5hj9-m76g-xrc8 |
| PyPI | apache-airflow-providers-apache-hdfs | 4.1.1 | PYSEC-2026-1138 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Airflow HDFS Provider | 0 – before 4.1.1 |
Weakness: CWE-829