Vulnerability · Published Nov 16, 2023 · Assigned by OpenNMS
CVE-2023-40314Cross-site scripting in bootstrap.jsp
Medium 5.8
In plain English
A medium-severity improper input validation in Horizon from The OpenNMS Group. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 38% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Cross-site scripting in bootstrap.jsp in multiple versions of OpenNMS Meridian and Horizon allows an attacker access to confidential session information. The solution is to upgrade to Horizon 32.0.5 or newer and Meridian 2023.1.9 or newer Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Moshe Apelbaum for reporting this issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.opennms:opennms-webapp | 32.0.5 | GHSA-c6xw-hg9q-3c9f |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| The OpenNMS Group | Horizon | 31.0.8 – before 32.0.4 |
| The OpenNMS Group | Meridian | see references |
Weakness: CWE-20, CWE-79 · Vector: CVSS:3.1/AV:A/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N