Vulnerability · Published Aug 18, 2023 · Assigned by GitHub_M
CVE-2023-40175Inconsistent Interpretation of HTTP Requests in puma
High 7.3
In plain English
A high-severity security flaw in puma from puma. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 58% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Puma is a Ruby/Rack web server built for parallelism. Prior to versions 6.3.1 and 5.6.7, puma exhibited incorrect behavior when parsing chunked transfer encoding bodies and zero-length Content-Length headers in a way that allowed HTTP request smuggling. Severity of this issue is highly dependent on the nature of the web site using puma is. This could be caused by either incorrect parsing of trailing fields in chunked transfer encoding bodies or by parsing of blank/zero-length Content-Length headers. Both issues have been addressed and this vulnerability has been fixed in versions 6.3.1 and 5.6.7. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | puma | 5.6.5-3+deb12u1 | DEBIAN-CVE-2023-40175 |
| Debian:13 | puma | 5.6.7-1 | DEBIAN-CVE-2023-40175 |
| Debian:14 | puma | 5.6.7-1 | DEBIAN-CVE-2023-40175 |
| RubyGems | puma | 5.6.7 | GHSA-68xg-gqqm-vgj8 |
| RubyGems | puma | 6.3.1 | GHSA-68xg-gqqm-vgj8 |
| Ubuntu:24.04:LTS | puma | 5.6.5-4ubuntu2 | UBUNTU-CVE-2023-40175 |
Affected products (as reported)
Weakness: CWE-444 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
References
- https://github.com/puma/puma/security/advisories/GHSA-68xg-gqqm-vgj8 x_refsource_CONFIRM
- https://github.com/puma/puma/commit/690155e7d644b80eeef0a6094f9826ee41f1080a x_refsource_MISC