Vulnerability · Published Sep 11, 2023 · Assigned by GitHub_M

CVE-2023-40032Potential segfault due to NULL pointer dereference in libvips

Medium 5.5

In plain English

A medium-severity null pointer dereference in libvips from libvips. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 17% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.5Medium
Exploit odds (30 days)0.3%top 83.3% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

libvips is a demand-driven, horizontally threaded image processing library. A specially crafted SVG input can cause libvips versions 8.14.3 or earlier to segfault when attempting to parse a malformed UTF-8 character. Users should upgrade to libvips version 8.14.4 (or later) when processing untrusted input.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12vips8.14.1-3+deb12u1DEBIAN-CVE-2023-40032
Debian:13vips8.14.4-1DEBIAN-CVE-2023-40032
Debian:14vips8.14.4-1DEBIAN-CVE-2023-40032

Affected products (as reported)

VendorProductVersions
libvips libvips < 8.14.4

Weakness: CWE-476 · Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

References