Vulnerability · Published Aug 16, 2023 · Assigned by Wordfence
CVE-2023-3958WP Remote Users Sync <= 1.2.12 - Authenticated (Subscriber+) Server Side Request Forgery
High 8.5
In plain English
A high-severity server-side request forgery in WP Remote Users Sync from frogerme. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 55% of all known vulnerabilities).
Official description
The WP Remote Users Sync plugin for WordPress is vulnerable to Server Side Request Forgery via the 'notify_ping_remote' AJAX function in versions up to, and including, 1.2.12. This can allow authenticated attackers with subscriber-level permissions or above to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services. This was partially patched in version 1.2.12 and fully patched in version 1.2.13.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| frogerme | WP Remote Users Sync | 0 – through 1.2.12 |
Weakness: CWE-918 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
References
- https://www.wordfence.com/threat-intel/vulnerabilities/id/2e78c759-4a54-4ee4-8eff-df91fe9dad46?source=cve
- https://plugins.trac.wordpress.org/browser/wp-remote-users-sync/trunk/inc/api/class-wprus-api-abstract.php#L674
- https://plugins.trac.wordpress.org/changeset/2946667/wp-remote-users-sync#file127
- https://plugins.trac.wordpress.org/changeset/2953845/wp-remote-users-sync#file0