Vulnerability · Published Aug 23, 2023 · Assigned by apache

CVE-2023-39441Apache Airflow SMTP Provider, Apache Airflow IMAP Provider, Apache Airflow: SMTP/IMAP client components allowed MITM due to missing Certificate Validation

Medium 5.9

In plain English

A medium-severity improper certificate validation in Apache Airflow from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 57% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)5.9Medium
Exploit odds (30 days)0.8%top 43.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Apache Airflow SMTP Provider before 1.3.0, Apache Airflow IMAP Provider before 3.3.0, and Apache Airflow before 2.7.0 are affected by the Validation of OpenSSL Certificate vulnerability. The default SSL context with SSL library did not check a server's X.509 certificate.  Instead, the code accepted any certificate, which could result in the disclosure of mail server credentials or mail contents when the client connects to an attacker in a MITM position. Users are strongly advised to upgrade to Apache Airflow version 2.7.0 or newer, Apache Airflow IMAP Provider version 3.3.0 or newer, and Apache Airflow SMTP Provider version 1.3.0 or newer to mitigate the risk associated with this vulnerability

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIapache-airflow2.7.0GHSA-5f35-pq34-c87q
PyPIapache-airflow2.7.0PYSEC-2026-1130
PyPIapache-airflow-providers-imap3.3.0GHSA-5f35-pq34-c87q
PyPIapache-airflow-providers-imap3.3.0PYSEC-2026-2368
PyPIapache-airflow-providers-smtp1.3.0GHSA-5f35-pq34-c87q
PyPIapache-airflow-providers-smtp1.3.0PYSEC-2026-2371

Affected products (as reported)

Weakness: CWE-295

References