Vulnerability · Published Jul 27, 2023 · Assigned by GitHub_M

CVE-2023-38489Kirby vulnerable to Insufficient Session Expiration after a password change

High 7.3

In plain English

A high-severity security flaw in kirby from getkirby. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 57% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.3High
Exploit odds (30 days)0.8%top 42.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Kirby is a content management system. A vulnerability in versions prior to 3.5.8.3, 3.6.6.3, 3.7.5.2, 3.8.4.1, and 3.9.6 affects all Kirby sites with user accounts (unless Kirby's API and Panel are disabled in the config). It can only be abused if a Kirby user is logged in on a device or browser that is shared with potentially untrusted users or if an attacker already maliciously used a previous password to log in to a Kirby site as the affected user. Insufficient Session Expiration is when a web site permits an attacker to reuse old session credentials or session IDs for authorization. In the variation described in this advisory, it allows attackers to stay logged in to a Kirby site on another device even if the logged in user has since changed their password. Kirby did not invalidate user sessions that were created with a password that was since changed by the user or by a site admin. If a user changed their password to lock out an attacker who was already in possession of the previous password or of a login session on another device or browser, the attacker would not be reliably prevented from accessing the Kirby site as the affected user. The problem has been patched in Kirby 3.5.8.3, 3.6.6.3, 3.7.5.2, 3.8.4.1, and 3.9.6. In all of the mentioned releases, the maintainers have updated the authentication implementation to keep track of the hashed password in each active session. If the password changed since the login, the session is invalidated. To enforce this fix even if the vulnerability was previously abused, all users are logged out from the Kirby site after updating to one of the patched releases.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistgetkirby/cms3.5.8.3GHSA-5mvj-rvp8-rf45
Packagistgetkirby/cms3.6.6.3GHSA-5mvj-rvp8-rf45
Packagistgetkirby/cms3.7.5.2GHSA-5mvj-rvp8-rf45
Packagistgetkirby/cms3.8.4.1GHSA-5mvj-rvp8-rf45
Packagistgetkirby/cms3.9.6GHSA-5mvj-rvp8-rf45

Affected products (as reported)

VendorProductVersions
getkirby kirby < 3.5.8.3>= 3.6.0, < 3.6.6.3>= 3.7.0, < 3.7.5.2>= 3.8.0, < 3.8.41>= 3.9.0, < 3.9.6

Weakness: CWE-613 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N

References