Vulnerability · Published Nov 17, 2023 · Assigned by mitre

CVE-2023-38320

High 7.5

In plain English

A high-severity security flaw in the opennds package (Debian). There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 62% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)7.5High
Exploit odds (30 days)1.0%top 38.4% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

An issue was discovered in OpenNDS Captive Portal before version 10.1.2. It has a show_preauthpage NULL pointer dereference that can be triggered with a crafted GET HTTP with a missing User-Agent header. Triggering this issue results in crashing OpenNDS (a Denial-of-Service condition). This problem was fixed in OpenWrt master, OpenWrt 23.05 and OpenWrt 22.03 on 28. August 2023 by updating OpenNDS to version 10.1.3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12openndsno fix listedDEBIAN-CVE-2023-38320
Debian:13opennds10.2.0+dfsg-1DEBIAN-CVE-2023-38320

Affected products (as reported)

VendorProductVersions
n/a n/a n/a

References