Vulnerability · Published Aug 29, 2023 · Assigned by mitre
CVE-2023-38283
Medium 5.3
In plain English
A medium-severity security flaw in the openbgpd package (Debian). Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 1.4% (higher than 72% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS NVD)5.3Medium
Exploit odds (30 days)1.4%top 28.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known
Official description
In OpenBGPD before 8.1, incorrect handling of BGP update data (length of path attributes) set by a potentially distant remote actor may cause the system to incorrectly reset a session. This is fixed in OpenBSD 7.3 errata 006.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | openbgpd | no fix listed | DEBIAN-CVE-2023-38283 |
| Debian:13 | openbgpd | 8.1-1 | DEBIAN-CVE-2023-38283 |
| Debian:14 | openbgpd | 8.1-1 | DEBIAN-CVE-2023-38283 |
| Ubuntu:22.04:LTS | openbgpd | no fix listed | UBUNTU-CVE-2023-38283 |
| Ubuntu:24.04:LTS | openbgpd | no fix listed | UBUNTU-CVE-2023-38283 |
| Ubuntu:25.10 | openbgpd | no fix listed | UBUNTU-CVE-2023-38283 |
| Ubuntu:26.04:LTS | openbgpd | no fix listed | UBUNTU-CVE-2023-38283 |
| Ubuntu:26.10 | openbgpd | no fix listed | UBUNTU-CVE-2023-38283 |