Vulnerability · Published Jul 27, 2023 · Assigned by GitHub_M
CVE-2023-37900Crossplane vulnerable to denial of service from large image
Low 3.4
In plain English
A low-severity uncontrolled resource consumption in crossplane from crossplane. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Crossplane is a framework for building cloud native control planes without needing to write code. In versions prior to 1.11.5, 1.12.3, and 1.13.0, a high-privileged user could create a Package referencing an arbitrarily large image containing that Crossplane would then parse, possibly resulting in exhausting all the available memory and therefore in the container being OOMKilled. The impact is limited due to the high privileges required to be able to create the Package and the eventually consistency nature of controller. This issue is fixed in versions 1.11.5, 1.12.3, and 1.13.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/crossplane/crossplane | 1.11.5 | GHSA-68p4-95xf-7gx8 |
| Go | github.com/crossplane/crossplane | 1.12.3 | GHSA-68p4-95xf-7gx8 |
| Go | github.com/crossplane/crossplane | 1.11.5, 1.12.3 | GO-2023-1979 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| crossplane | crossplane | < 1.11.5>= 1.12.0, < 1.12.3 |
Weakness: CWE-400, CWE-770 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:N/I:N/A:L