Vulnerability · Published Jul 12, 2023 · Assigned by apache
CVE-2023-37582Apache RocketMQ: Possible remote code execution when using the update configuration function
Critical 9.8
In plain English
A critical-severity code injection in Apache RocketMQ from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 90.4% (higher than 99.8% of all known vulnerabilities). Ready-made attack tooling exists: Nuclei, public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
The RocketMQ NameServer component still has a remote command execution vulnerability as the CVE-2023-33246 issue was not completely fixed in version 5.1.1. When NameServer address are leaked on the extranet and lack permission verification, an attacker can exploit this vulnerability by using the update configuration function on the NameServer component to execute commands as the system users that RocketMQ is running as. It is recommended for users to upgrade their NameServer version to 5.1.2 or above for RocketMQ 5.x or 4.9.7 or above for RocketMQ 4.x to prevent these attacks.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.rocketmq:rocketmq-namesrv | 4.9.7 | GHSA-gpq8-963w-8qc9 |
| Maven | org.apache.rocketmq:rocketmq-namesrv | 5.1.2 | GHSA-gpq8-963w-8qc9 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache RocketMQ | 5.0.0 – through 5.1.10 – through 4.9.6 |
Weakness: CWE-94 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H