Vulnerability · Published Jul 14, 2023 · Assigned by GitHub_M

CVE-2023-37464Incorrect Authentication Tag length usage in AES GCM decryption in OpenIDC/cjose

High 8.6

In plain English

A high-severity broken cryptography in cjose from OpenIDC. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 54% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.6High
Exploit odds (30 days)0.7%top 46.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

OpenIDC/cjose is a C library implementing the Javascript Object Signing and Encryption (JOSE). The AES GCM decryption routine incorrectly uses the Tag length from the actual Authentication Tag provided in the JWE. The spec says that a fixed length of 16 octets must be applied. Therefore this bug allows an attacker to provide a truncated Authentication Tag and to modify the JWE accordingly. Users should upgrade to a version >= 0.6.2.2. Users unable to upgrade should avoid using AES GCM encryption and replace it with another encryption algorithm (e.g. AES CBC).

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8cjose0.6.1-3.module_el8.8.0+3591+c9939da8ALSA-2023:4418
AlmaLinux:9cjose0.6.1-13.el9_2.almaALSA-2023:4411
AlmaLinux:8cjose-devel0.6.1-3.module_el8.8.0+3591+c9939da8ALSA-2023:4418
AlmaLinux:8mod_auth_openidc2.4.9.4-1.module_el8.7.0+3305+9a59f0c3ALSA-2023:4418
Alpine:v3.20cjose0.6.2.2-r0ALPINE-CVE-2023-37464
Alpine:v3.21cjose0.6.2.2-r0ALPINE-CVE-2023-37464
Alpine:v3.22cjose0.6.2.2-r0ALPINE-CVE-2023-37464
Alpine:v3.23cjose0.6.2.2-r0ALPINE-CVE-2023-37464
Alpine:v3.24cjose0.6.2.2-r0ALPINE-CVE-2023-37464
Debian:12cjose0.6.2.1-1+deb12u1DSA-5472-1
Debian:12cjose0.6.2.1-1+deb12u1DEBIAN-CVE-2023-37464
Debian:13cjose0.6.2.2-1DEBIAN-CVE-2023-37464
Debian:14cjose0.6.2.2-1DEBIAN-CVE-2023-37464
Rocky Linux:8cjose0:0.6.1-3.module+el8.8.0+1406+4a7f5371RLSA-2023:4418
Rocky Linux:8mod_auth_openidc0:2.4.9.4-1.module+el8.7.0+1061+55d14382RLSA-2023:4418
Ubuntu:22.04:LTScjose0.6.1+dfsg1-3ubuntu1.1USN-6307-1
Ubuntu:22.04:LTScjose0.6.1+dfsg1-3ubuntu1.1UBUNTU-CVE-2023-37464
Ubuntu:24.04:LTScjoseno fix listedUBUNTU-CVE-2023-37464
Ubuntu:25.10cjoseno fix listedUBUNTU-CVE-2023-37464
Ubuntu:26.04:LTScjoseno fix listedUBUNTU-CVE-2023-37464
Ubuntu:26.10cjoseno fix listedUBUNTU-CVE-2023-37464

Affected products (as reported)

VendorProductVersions
OpenIDC cjose < 0.6.2.2

Weakness: CWE-327 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N

References