Vulnerability · Published Jul 11, 2023 · Assigned by GitHub_M

CVE-2023-37280Pimcore admin UI vulnerable to Cross-site Scripting in two factor authentication setup page

Medium 5.0

In plain English

A medium-severity cross-site scripting in admin-ui-classic-bundle from pimcore. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.0Medium
Exploit odds (30 days)0.6%top 52.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Pimcore Admin Classic Bundle provides a Backend UI for Pimcore based on the ExtJS framework. An admin who has not setup two factor authentication before is vulnerable for this attack, without need for any form of privilege, causing the application to execute arbitrary scripts/HTML content. This vulnerability has been patched in version 1.0.3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistpimcore/admin-ui-classic-bundle1.0.3GHSA-hqv9-6jqw-9g8m

Affected products (as reported)

VendorProductVersions
pimcore admin-ui-classic-bundle < 1.0.3

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L

References