Vulnerability · Published Jul 11, 2023 · Assigned by GitHub_M
CVE-2023-37271RestrictedPython vulnerable to arbitrary code execution via stack frame sandbox escape
High 8.4
In plain English
A high-severity security flaw in RestrictedPython from zopefoundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 58% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
RestrictedPython is a tool that helps to define a subset of the Python language which allows users to provide a program input into a trusted environment. RestrictedPython does not check access to stack frames and their attributes. Stack frames are accessible within at least generators and generator expressions, which are allowed inside RestrictedPython. Prior to versions 6.1 and 5.3, an attacker with access to a RestrictedPython environment can write code that gets the current stack frame in a generator and then walk the stack all the way beyond the RestrictedPython invocation boundary, thus breaking out of the restricted sandbox and potentially allowing arbitrary code execution in the Python interpreter. All RestrictedPython deployments that allow untrusted users to write Python code in the RestrictedPython environment are at risk. In terms of Zope and Plone, this would mean deployments where the administrator allows untrusted users to create and/or edit objects of type `Script (Python)`, `DTML Method`, `DTML Document` or `Zope Page Template`. This is a non-default configuration and likely to be extremely rare. The problem has been fixed in versions 6.1 and 5.3.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | restrictedpython | no fix listed | DEBIAN-CVE-2023-37271 |
| Debian:13 | restrictedpython | 6.2-1 | DEBIAN-CVE-2023-37271 |
| Debian:14 | restrictedpython | 6.2-1 | DEBIAN-CVE-2023-37271 |
| PyPI | restrictedpython | 5.3 | GHSA-wqc8-x2pr-7jqh |
| PyPI | restrictedpython | 5.3 | PYSEC-2023-118 |
| PyPI | restrictedpython | 6.1 | GHSA-wqc8-x2pr-7jqh |
| PyPI | restrictedpython | 5.3 | GHSA-wqc8-x2pr-7jqh |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| zopefoundation | RestrictedPython | >= 6.0a1.dev0, < 6.1< 5.3 |
Weakness: CWE-913 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:L