Vulnerability · Published Jul 5, 2023 · Assigned by GitHub_M
CVE-2023-364581Panel vulnerable to ommand injection when entering the container terminal
Medium 6.3
In plain English
A medium-severity command injection in 1Panel from 1Panel-dev. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 2.3% (higher than 83% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)6.3Medium
Exploit odds (30 days)2.3%top 16.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known
Official description
1Panel is an open source Linux server operation and maintenance management panel. Prior to version 1.3.6, an authenticated attacker can craft a malicious payloads to achieve command injection when entering the container terminal. The vulnerability has been fixed in v1.3.6.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/1Panel-dev/1Panel | 1.3.6 | GHSA-7x2c-fgx6-xf9h |
| Go | github.com/1Panel-dev/1Panel | 1.3.6 | GO-2023-1888 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| 1Panel-dev | 1Panel | , 1.3.6 |
Weakness: CWE-77 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
References
- https://github.com/1Panel-dev/1Panel/security/advisories/GHSA-7x2c-fgx6-xf9h x_refsource_CONFIRM
- https://github.com/1Panel-dev/1Panel/releases/tag/v1.3.6 x_refsource_MISC