Vulnerability · Published Jun 27, 2023 · Assigned by GitHub_M
CVE-2023-34240Weak passwords allowed in cloudexplorer-lite
Medium 6.5
In plain English
A medium-severity security flaw in CloudExplorer-Lite from CloudExplorer-Dev. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 40% of all known vulnerabilities).
Official description
Cloudexplorer-lite is an open source cloud software stack. Weak passwords can be easily guessed and are an easy target for brute force attacks. This can lead to an authentication system failure and compromise system security. Versions of cloudexplorer-lite prior to 1.2.0 did not enforce strong passwords. This vulnerability has been fixed in version 1.2.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| CloudExplorer-Dev | CloudExplorer-Lite | < 1.2.0 |
Weakness: CWE-521 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N