Vulnerability · Published Jul 25, 2023 · Assigned by apache
CVE-2023-34189Apache InLong: General user can delete and update process
Medium 6.5
In plain English
A medium-severity security flaw in Apache InLong from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.3% (higher than 70% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Exposure of Resource to Wrong Sphere Vulnerability in Apache Software Foundation Apache InLong.This issue affects Apache InLong: from 1.4.0 through 1.7.0. The attacker could use general users to delete and update the process, which only the admin can operate occurrences. Users are advised to upgrade to Apache InLong's 1.8.0 or cherry-pick https://github.com/apache/inlong/pull/8109 to solve it.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.inlong:inlong-manager | 1.8.0 | GHSA-86pw-4rqp-6x7v |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache InLong | 1.4.0 – through 1.7.0 |
Weakness: CWE-668