Vulnerability · Published May 31, 2023 · Assigned by GitHub_M
CVE-2023-33966Deno missing "--allow-net" permission check for built-in Node modules
High 8.6
In plain English
A high-severity privilege mismanagement in deno from denoland. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities).
Official description
Deno is a runtime for JavaScript and TypeScript. In deno 1.34.0 and deno_runtime 0.114.0, outbound HTTP requests made using the built-in `node:http` or `node:https` modules are incorrectly not checked against the network permission allow list (`--allow-net`). Dependencies relying on these built-in modules are subject to the vulnerability too. Users of Deno versions prior to 1.34.0 are unaffected. Deno Deploy users are unaffected. This problem has been patched in Deno v1.34.1 and deno_runtime 0.114.1 and all users are recommended to update to this version. No workaround is available for this issue.
Affected products (as reported)
Weakness: CWE-269 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N
References
- https://github.com/denoland/deno/security/advisories/GHSA-vc52-gwm3-8v2f x_refsource_CONFIRM
- https://github.com/denoland/deno/releases/tag/v1.34.1 x_refsource_MISC