Vulnerability · Published Jul 19, 2023 · Assigned by HashiCorp
CVE-2023-3300Nomad Search API Leaks Information About CSI Plugins
Medium 5.3
In plain English
A medium-severity security flaw in Nomad from HashiCorp. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 47% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)0.6%top 52.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
HashiCorp Nomad and Nomad Enterprise 0.11.0 up to 1.5.6 and 1.4.1 HTTP search API can reveal names of available CSI plugins to unauthenticated users or users without the plugin:read policy. Fixed in 1.6.0, 1.5.7, and 1.4.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/hashicorp/nomad | 1.4.11 | GHSA-v5fm-hr72-27hx |
| Go | github.com/hashicorp/nomad | 1.5.7 | GHSA-v5fm-hr72-27hx |
| Go | github.com/hashicorp/nomad | 1.4.11, 1.5.7 | GO-2024-2671 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| HashiCorp | Nomad | 0.11.0 – through 1.4.10.11.0 – through 1.5.6 |
| HashiCorp | Nomad Enterprise | 0.11.0 – through 1.4.10.11.0 – through 1.5.6 |
Weakness: CWE-266 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N