Vulnerability · Published May 23, 2023 · Assigned by GitHub_M
CVE-2023-32697Sqlite-jdbc vulnerable to remote code execution when JDBC url is attacker controlled
High 8.8
In plain English
A high-severity code injection in sqlite-jdbc from xerial. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.6% (higher than 76% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
SQLite JDBC is a library for accessing and creating SQLite database files in Java. Sqlite-jdbc addresses a remote code execution vulnerability via JDBC URL. This issue impacting versions 3.6.14.1 through 3.41.2.1 and has been fixed in version 3.41.2.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | xerial-sqlite-jdbc | 3.40.1.0+dfsg-1+deb12u1 | DEBIAN-CVE-2023-32697 |
| Debian:13 | xerial-sqlite-jdbc | 3.42.0.0+dfsg-1 | DEBIAN-CVE-2023-32697 |
| Debian:14 | xerial-sqlite-jdbc | 3.42.0.0+dfsg-1 | DEBIAN-CVE-2023-32697 |
| Maven | org.xerial:sqlite-jdbc | 3.41.2.2 | GHSA-6phf-6h5g-97j2 |
| Ubuntu:22.04:LTS | xerial-sqlite-jdbc | no fix listed | UBUNTU-CVE-2023-32697 |
| Ubuntu:24.04:LTS | xerial-sqlite-jdbc | no fix listed | UBUNTU-CVE-2023-32697 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| xerial | sqlite-jdbc | >= 3.6.14.1, < 3.41.2.2 |
Weakness: CWE-94 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
References
- https://github.com/xerial/sqlite-jdbc/security/advisories/GHSA-6phf-6h5g-97j2 x_refsource_CONFIRM
- https://github.com/xerial/sqlite-jdbc/releases/tag/3.41.2.2 x_refsource_MISC